View Issue Details

IDProjectCategoryView StatusLast Update
0012711MediaMonkey (current)Framework: Taggingpublic2016-09-08 17:44
Reporterlowlander 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.6 
Target Version4.1.7Fixed in Version4.1.9 
Summary0012711: Lyric lookup fails (regression)
DescriptionAZLyrics isn't returning proper lyrics: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=80670
TagsNo tags attached.
Fixed in build1753

Relationships

related to 0012146 closedlowlander Lyrics retrieval gets wrong info 

Activities

Ludek

2015-04-23 21:52

developer   ~0042465

I can confirm that all lyrics returned by AZLyrics returns just:
"Visit www.azlyrics.com for these lyrics."


Fixed in build 4.1.7.1741 (abandoned AZLyrics)

peke

2015-04-24 00:11

developer   ~0042468

Verified 1741

Ludek

2015-08-07 13:58

developer   ~0042806

Last edited: 2015-08-10 11:17

View 9 revisions

Starting from today the QUnit test for lyrics lookup fails.

This time it seems that

1) [lyrics.wikia.com] always returns 404 because the search root needs to be [lyrics.wikia.com/wiki/] instead of just [lyrics.wikia.com]

2) [letras.terra.com.br] returns another HTML form that MM scripts (lyricsSearch.js) fail to parse.

3) We need to find more alternate servers, currently we search only [lyrics.wikia.com] and [letras.terra.com], all the others are either no longer available or don't wish to be exposed for our auto-lookup (like AZLyrics).

Ludek

2015-08-10 11:19

developer   ~0042811

Last edited: 2015-08-10 12:26

View 3 revisions

Items 1&2 are fixed in build 4.1.9.1753

Re 3) possible alternate servers could be added from new version of lyricator ( http://www.happymonkeying.com/plugin.php?q=300091 ), servers like mp3lyrics.org, lyricstime.com, metrolyrics.com, webservices.lyrdb.com, elyrics.net, seekalyric.com, genius.com, hiplyrics.com

Ludek

2015-08-10 13:48

developer   ~0042813

Last edited: 2015-08-10 14:00

View 6 revisions

re 3) some of them do not work anymore (LyrDB, Hiplyrics, Mp3Lyrics).

But these 5 new alternate servers work fine: SeekALyric, MetroLyrics, ELyrics, LyricsMode, SongColeta

I added them and now we search up to 7 servers (instead of 2).

Added in build 4.1.9.1753 and merged into 5.0.0 (did not merge to MM8)

peke

2015-08-12 23:10

developer   ~0042824

Verified 1753